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Summary 

This report describes a number of training modules for ERDAS Imagine, covering 
basic image processing techniques. 
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Introduction 
 
ERDAS Imagine is a frequently used software package within the Remote Sensing 
Section. Over a number of years experience has been gained in applying its 
functionality to a variety of projects both in the UK and overseas. The aim of this 
report is to present a collection of modules for knowledge transfer and training 
purposes.  

 

The collection of data, which is referred to within this report, is available from the 
Remote Sensing Section. 

1 Module 1 - Basics 
 
Main Menu 
 
When ERDAS IMAGINE is opened the main interface starts automatically (see below). This menu bar, 
which can be positioned at any convenient place on the screen, contains, through a series of drop-down 
menus, all the commands and processing features used in IMAGINE. 
 

 
 

 
From left to right the buttons are: 
 
• Viewer: clicking on this with the left mouse button opens the viewer, this is the window in which 

imagery is displayed and simple processing takes place. 
• Import: contains procedures for importing data into the native format of IMAGINE (.img). Also 

contains procedures for exporting data to other commonly used geo-data formats such as GeoTiff, 
DGN, GRID, Shapefile. 

• Data Prep: used to access fairly common routines, such as creating a new image, subsetting 
(cutting out) an image, and reprojection of the data. 

• Composer: is used for the production of maps from georeferenced data. 
• Interpreter: contains many more advanced data processing options, these may concern processing 

the imagery to enhance the spectral or spatial information, or even some more basic options such 
as stacking a series of image layers into one image. 

• Catalog: is used to organise your data and find out simple information about it. 
• Classifier: used to classify image pixels based on their values in different spectral bands. 
• Modeler: allows the user to produce graphical models for specialist routines, which may not be 

available from the normal menus. 
• Vector: contains menus for the vector utilities, such as cleaning and building vector data, 

conversion to raster etc. 
• Radar: menu for the radar utilities. 
• VirtualGIS: starts the VGIS viewer – the main interface for 3D display of data, also allows the 

user to produce movies. 
• OrthoBASE: tools to set up the parameters required to view an image stereo pair 
• Stereo: tools for the viewing of stereo imagery, also allows for feature digitisation in 3D. 
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The Viewer. 
 
The viewer in IMAGINE is the tool used to visualise both raster and vector data in 2D, and is opened 
by left clicking the Viewer icon on the main tool bar. There are two types of viewer available in 
Imagine 8.6, the ‘Classic Viewer’ and Geospatial Light Table (GLT). 
 
Any number of Classic Viewers can be open at the same time; therefore each is automatically 
numbered and the filename is displayed in the title bar to help with organisation. The data in the 
viewers can be geolinked so that, for example, panning in one window will automatically cause the 
others windows to pan to the same location. 
 

There are four sections to the Classic Viewer. 

1. Menu: gives access to applications. 

2. Icons: One-click access to commonly used applications. 

3. Display area: the area where data are visualised. 

4. Status Bar: gives the co-ordinates of the cursor position and information on the function of an 
icon. 

 

 

 

 

 

The GLT is a Classic Viewer with a few handy add-ons. Multiple classic viewers can be opened in a 
GLT, and there are tools and icons to simplify many common processes. Also, the GLT is similar to a 
MapInfo Workspace i.e. the session can be saved to enable quick return to the same screen layout. 

 

 

 2. Icons 

3. Display area 

4. Status bar 

1. Menu 
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Opening Image Data. 

 

In the Viewer menu, select file| Open, then Raster Layer. 
 

 
 

The Select Layer to Add dialog opens (see above), this is the standard dialog for opening files in 
IMAGINE.  It allows the user to navigate to the file of interest and open it, much the same as in any 
windows based application. 

 

To open a file quickly, the Open Layer icon  from the Viewer Icon panel can be used. 
Files can also be dragged into the Viewer from Windows Explorer but fewer options are available this 
way. 

 

 

Change drive or directory 

Choose the type of file to be opened 

Select the file to be opened 

Recent files opened 

Lists recently visited directories 
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Navigate to the E Drive on your machine, go to the ERDAS_Training folder and select the Examples 
folder. Ensure that the Files of Type is set to IMAGINE Image (*.img), find the file 
Assynt_6band.img and single click on it to highlight. The name will appear in the file name box in the 
Select Layer to Add dialogue. Now click on the Raster Options tab at the top of the Select Layer to 
Add dialogue.  Ensure that the Display as is set to True Color, alter the Layers to Colors so that 
Layer 3 is set to display in Red, layer 2 in Green and Layer 1 in Blue. Also ensure that the other 
settings are as shown below. 

 

 

 

 

Now click OK. You will now have the image loaded into the viewer. The image should be a true 
colour composite; that is the colours displayed will be similar to those in real life. 

 

What does the ‘Layers to Colors’ option mean? 

 

The Landsat 7 sensor acquired the image you have just displayed, this records light reflected from the 
earth’s surface. The satellite has multiple sensors onboard; each records reflectance in a distinct region 
of the electromagnetic spectrum, these regions are known as bands. Landsat 7 data records 9 bands, 
these bands handled as ‘layers’ in IMAGINE. 

 

So, when you opened the image you put band 3, which corresponds to light reflected in the red region 
of the EM spectrum in the Red colour display. You also put Band 2, which records the reflected green 
light in the Green display, and Band 1, corresponding to the reflected blue light in the Blue display. 
Since the bands are displayed in the same colour as the region of the EM spectrum that they relate to, 
colours in the resultant image will match those that you are used to seeing in a normal colour photo. 

 

It is possible to create false and pseudo colour composites by displaying bands in different colours, but 
we will come onto that later. 

 

Zooming and Roaming. 

Note that the GLT contains more functions than the Classic Viewer. 
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Maximise the Classic Viewer, right click anywhere within the display area, a Quick View menu will 
pop up. Move down and select the Fit Image to Window option. This is also possible using an icon 

shortcut in the GLT . 

 

1.1 WE WILL NOW LOOK AT THE FUNCTIONS AVAILABLE IN THE VIEWER. 

• ZOOMING AND ROAMING CAN BE DONE TWO WAYS: 

 

¾ Go to View | Zoom | In by 2 on the viewer menu, this will zoom in by 2 times. Open the Quick 
View menu and select the Fit Image to Window option to get back to the original size. 

¾ An easier way to zoom in is to use the  icon, left click, hold and drag to define an area to 
zoom into. 

¾ You can now use the  to roam about the image. 

 

• Find the viewing scale: 

 

¾ In the Viewer Menu go to View | Scale | Scale Tool, a dialog will pop up indicating 
the scale you are currently looking at.  Use the dialog to zoom to 100 000 scale (tip: leave out 

the space). Now select the  icon, position it in the centre of the viewer and left click 
once – what is the viewing scale now? Repeat this last step again – what is the viewing scale 
and what does the image look like? Can you think why this maybe? 

¾ In the GLT the scale view is constantly visible in the Zoom/rotate portion of the 
window. 

 

• Image rotation in GLT: 

¾ Using , click the middle mouse button to interactively rotate the image. 

¾ Rotation and alignment can also be altered by clicking the right mouse button in the bottom 
right hand corner of the GLT and choosing between grid north, true north, or file north. 

 

• In-view magnification using the  icon in GLT turns the cursor into a magnifying 
glass. 

 

 

1.1.1.1 DERIVING INFORMATION ABOUT THE IMAGE 

 

Image Information. 
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¾ From the viewer menu go to Utility | Layer info, this can also be accessed by clicking the 

 icon. This will open a dialog: 

 

 
 

This dialog is useful for adding projection information to an image. This is something that we will 
address later. 

 

¾ From the viewer menu select Utility | Inquire Cursor a red cursor will appear on the 
image and a dialog will open. The cursor can be moved around and the values in the 
dialog will alter. 
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The file pixel column gives information about the pixel values of the image.  Pixel values are related to 
the surface reflectance in that band. The LUT value column shows the value for that pixel after it has 
been contrast stretched. 

 

Altering the appearance of the image: 

 

Contrast Stretching: 

 

Multispectral satellite imagery is commonly recorded in an 8bit format (although RADAR is generally 
16-bit); a pixel could therefore have a value anywhere between 0 and 255 (82 = 256). However it is 
very rare that information recorded from an area will utilise this full range, which leads to images 
looking either overly dark or bright when displayed. To resolve this the pixel values of a band need to 
be ‘stretched’ so they occupy the full 0-255 range, the process for doing this is called contrast 
stretching. 

 

• From the viewer menu choose File | Clear to clear the viewer. 

• Open the same image in the same way as before ensuring that bands 3, 2 and 1 are loaded into red, 
green and blue, however this time, in the Raster Options check the No Stretch box. The image 
will open but this time it will be very dark – it needs contrast stretching!! 

• From the viewer menu select Raster | Contrast | Standard Deviation Stretch. IMAGINE will 
apply a stretch based on the statistics of the data. 

• The result looks a little too bright; this is because of atmospheric haze affecting the Blue band. To 
remove this we need to stretch the data interactively. 

• Close the image and re-open as before. 

• From the viewer menu choose Raster | Contrast | Breakpoints a dialog will open. 
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The breakpoint editor shows three histograms of the image data, one for each of the bands/monitor 
colour guns. These are essentially frequency plots, indicating the pixel distribution throughout the 8-bit 
range. The plots indicate the pixel value distribution of the original image. At present the data have not 
been stretched, therefore the plots do not occupy the entire range of possible pixel values. We want to 
stretch the histograms so that the minimum and maximum values are at the ends of the 8-bit range (i.e. 
so the coloured histograms fill the entire 0 – 255 range). 

 

• In the breakpoint editor, ensure that the arrow pointer is selected. 

• Move the cursor to the 0,0 position in the red histogram, the cursor will change to a cross 
indicating that the cursor is over a breakpoint. Click and drag the breakpoint along the x-axis to the 
start of the red histogram, release when there. 

• Now move the cursor to the top right corner of the red histogram, where the line intersects the 
edge of the box. 

• Click and drag this breakpoint, along the top of the x-axis, to the end of the red distribution, then 
release. Your breakpoint editor should now look as shown below: 
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The grey histogram is the original data distribution, while the red histogram shows that the effect of the 
stretch is to distribute the data evenly throughout the 8-bit range. 

 

• Now repeat the prior steps for the green and blue bands. 

• Ensure that Whole Image is checked for the Histogram Source and Lookup table is checked for 
the Apply To, then click apply all, the image should now look more pleasing to the eye. 

 

A Lookup Table is a table containing the input and output values for your stretch; the system then 
refers to this table to display the image in the correct way. A Lookup Table has the advantage of not 
altering the actual pixel values, therefore the original data is maintained. If the Apply To Image File 
option is selected then the pixels will adopt a new value based on the stretch. 

 

• If the image appears to have ‘too much’ of one colour then it is possible to move the upper 
breakpoint back a little; this will have the effect of decreasing the amount of this colour in the 
image. 

• Similarly if too little of a colour is present then the upper breakpoint for that colour can be moved 
forward (to the left), this will increase the amount of that colour in the image. 
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• NOW EXPERIMENT WITH THE INSERT BREAKPOINTS BUTTON , AND ADD 
BREAKPOINTS TO THE MIDDLE OF THE LINE IN THE EDITOR. 

• What is the effect of moving these new breakpoints? You can use these to stretch bimodal 
distributions such as in the red histogram above. 

• When you have reached a stretch that you like, save the breakpoints: In the Breakpoint Editor 
click on Save at the bottom of the dialog. A new dialog will appear in which you choose the 
destination and file name for the saved breakpoints. Give the breakpoints the file name: 
Assynt_321_bps and save it to the same directory that the image is in. 

• Whenever this image is opened using the stretch option this will be the stretch that will be applied. 

 

 

 

 

To decrease the amount of green this breakpoint 
is moved the right. 

To increase the amount of blue this
breakpoint is moved to the left. 
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Displaying different Bands 

 

As already mentioned satellite imagery often has more than three bands, however the computer monitor 
only has three colour guns/channels (red, green and blue). Therefore a maximum of 3 bands can be 
displayed at once. Until now we have been working with a true-colour composite, bands 321 displayed 
in red, green and blue. However it is often useful to display other bands, since these provide 
information from different regions of the EM spectrum. For example bare rock and soil reflect strongly 
in the mid-infrared region – a region corresponding to Landsat’s band 7, while green vegetation reflects 
strongly in the region corresponding to Landsat’s band 4. We may therefore want to include these 
bands when displaying the data. One way of doing this is to use the Raster Options when opening the 
image, however this is not very convenient if you want to change the bands frequently. 

 

• Keep the same image in the viewer; you should already have Bands 3, 2 and 1 displayed to give a 
true-colour image. 

• From the viewer menu select Raster | Bands Combinations, a dialog will appear: 

 

 
 

• The middle three boxes allow you to set which layer/band is displayed in which colour gun of the 
monitor.  This can also be done using the boxes on the right. 

• What happens if all three layers are set to be the same? Why do you think this is? 

• Set the bands to be Red = Layer 6, Green = Layer 4, Blue = Layer 1. This is called a 7,4,1 band 
combination. (In this case layer 6 in the image is band 7 from the satellite, this is because band 6 
from Landsat is the thermal band and has a different spatial resolution to the others and so was not 
included when we produced the image). 

• You will notice that the image will be dark once again, this is because you only stretched the first 
three bands. Open the breakpoint editor and stretch bands 6 and 4. Save these to a file with a 
relevant name. 

 

Altering the band combination is quicker in the GLT using the Spectral tools on the right side of the 
window. 

 

Opening a Greyscale Image 

 

Black and White Aerial Photography (and panchromatic satellite imagery) is saved as a single band and 
is therefore displayed as a greyscale image, the tone of which depends on the value of the pixels. 
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• With the satellite image of the Assynt area still open in the viewer, select File | Open | Raster 
Layer, navigate to the file called Assynt_photo_mos.img, highlight it and then click the Raster 
Options tab. 

• Ensure that the Display as option is set to Greyscale and that the No Stretch box is Unchecked. 
Click OK. 

 

An aerial photographic mosaic will open on top of the satellite image. This has much finer resolution 
than the satellite image so take some time to zoom and roam to explore the imagery. Use the Image 
Information utility to find the resolution (pixel size) of the image. 

 

Finding a Co-ordinate on the Image 

 

Sometimes it is useful to be able to type in a co-ordinate and have the system take you there. 

 

• Open the Inquire Cursor from the Utility menu as you did before; alternatively this can be 

opened using the  icon. 

• Alter the numbers in the dialogue box so that X = 223353 and Y = 911062. Press Return when the 
numbers are entered and the curser will jump to this position. 

• The cursor will now have moved to the edge of a Loch, use the zoom tool to zoom in on this area. 

 

Making Measurements 

 

Since the imagery used in IMAGINE is georeferenced it is possible to make measurements of features. 
Here we are going to use the measurement tool to find the length, perimeter and area of the loch. 

 

• From the Viewer menu select Utility | Measure, alternatively click the  icon. 

• A dialog will open, this has a selection of icons that are used to make the measurements and an 
area in which the measurements will be displayed. The user can change the units of measurements 
also. 
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• Select the Measure Perimeters and Areas tool digitise a polygon round the shore of the loch. 
Left click to start the polygon then left click to place vertices, double left click to close the polygon 
and obtain the measurement. 

• Now use the Measure Lengths and Angles tool to find the length of the loch. 

• Make a note of the measurements and close the toll down, there is no need to save the output. 

1.1.1.2 EXAMINING SPATIAL RELATIONSHIPS BETWEEN TWO DATASETS 

 

We still have two datasets open in the same viewer, often it is useful to be able to change which is 
displayed on top. A method for comparing the two images is also useful, especially for checking 
georeferenced data. 

 

• From the viewer menu select View | Arrange Layers, this will open a new menu window. This 
window shows what layers you have loaded into the viewer in the order that they are loaded i.e. 
top on the list is displayed upper most in the viewer. Simply clicking and dragging the top layer 
underneath the second layer and clicking the apply button will change the layer order. 

 

• Spatial relationships can be examined by using options available form the Utilities menu: 

¾ Utility | Blend will open a dialog with a sliding bar, moving this bar will blend the top layer 
into the lower layer. 

¾ Utility | Swipe allows a similar operation, however this time the upper image is ‘rolled’ 
backwards and forwards or up and down over the lower image – this is a very useful 
operation. 

¾ Utility | Flicker allows the upper image to be turned on and off. 

¾ All three of these can be automatic or manual, in practice the manual option usually works 
the best. 

Results of measurements are displayed here. 

Change the units of measurements 

Measure points 

Measure lengths and angles 

Measure rectangular areas 

Measure perimeters and areas 
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• Use both the satellite image (in whichever band combination you want – you can change these half 
way through) and the aerial photo, and a combination of the techniques we have covered, to 
answer the following questions: 

 

1. What is the projection of the satellite image (Image Information)? 

 

2. What colour does the snow (at X= 229242, Y = 886392) on the satellite image appear in a 457 
band combination? (Note the image will need stretching after the bands have been changed). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

21

Module 2 – Import/Export 
Importing and Exporting – 1. Introducing the Import/Export menu 

 

This module assumes knowledge of 

 

- Imagine Viewer 

 

Imagine allows the import and export of both raster and vector files in a number of formats. Some files 
such as GeoTiff can be displayed without first importing. However, if raster files are going to be 
manipulated within Imagine, it is usually recommended that these files are imported first. This 
conversion to ‘.img’ format will allow faster display due to the presence of pyramid layers and expands 
the number processing options available. 

 

With respect to vector data, IMAGINE will display ArcInfo coverages and ArcView shapefiles without 
the requirement to import them. However, there are a number of bugs when displaying shapefiles, 
therefore it can be preferable to import these first. ERDAS uses ArcInfo coverages as its native format, 
along with ‘annotation layers’, ‘overlay layers’ and ‘areas of interest’ files. 

 

Typical raster files that can be exported/imported are TIFF, GeoTIFF, USGS DEM, JPEG, Generic 
Binary, DTED… 

 

Typical vector files that can be exported/imported are shapefiles, DXF, ARCGEN. 

 

A complete list of files that can be written and read directly and those that can be imported/exported 
can be found in the appendix. 

 

1. To access the import and export options click the Import/Export button on the IMAGINE 

Icon Panel    (This may take a few seconds to initialise). 

 

2. The Import/Export menu will open. The main functions are illustrated below. 
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We will now work through a number of examples, showing the basic import and export procedures. 

 

Import/Export Toggle 

Type of input file 

Input media File/CD-
ROM/Tape  

Location of output
file 

Input file selector 

Allows viewing of header
and file date for certain
file types 
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Importing and Exporting – 2. Importing and Overlaying Raster Map Data 

 

This module assumes knowledge of 
 

- ImagineViewer 

 

Once an image has been georeferenced or orthorectified, other data can be overlaid to explore spatial 
relationships between datasets. Overlaying Ordnance Survey 1:10,000 scale raster maps provides 
useful location information and the merged datasets can be printed out using Map Composer. 

 

2. Open E:\ERDAS_Training\Examples\Import_Export\nc21sw.tif, in a new Viewer. 

 

Ordnance Survey 10K raster maps are available on the corporate network drives. The map we 
are going to be using has been copied to the Training Examples folder for you. 

 

3. The image is in GeoTiff format and has an associated .tfw file that contains some projection 
information. Navigate to E:\ERDAS_Training\Examples\Import_Export using Windows 
Explorer and open nc21sw.tfw. 

 

 
 

You can see that the file contains information on the pixel size and the upper left co-ordinates. 
In order to overlay this map onto an image with complete Projection details, IMAGINE needs 
information on the measurement units and the Projection system. 
 

4. In order to add the missing projection details the image needs to be imported in .img format. 

Click the Import/Export button on the IMAGINE Icon Panel  

    (This may take several seconds to initialise) 

 

5. From the Import/Export menu ensure that the Import option is toggled and select the file 
Type: as GeoTIFF, from the drop down menu. Now change the Media: to File. 

 

Specify the Input File as nc21sw.tif (path E:\ERDAS_Training\Examples\Import_Export\) 
and the Output File as nc21sw.img to the same directory. Click OK. 

 

Pixel size 

Upper left co-
ordinates 
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6. When the Import TIFF menu opens check the input and output images are correct and click 

Import Options. 

 

 
 

7. The Import Options menu will open. Confirm that the Create Pyramid Layers is checked 
and the Ignore Zero in Output Stats in unchecked, and click OK. 

 

 
 

Pyramid layers are reduced resolution images stored within the .img file. Although not 
essential they allow fast loading, panning and updating of the image within the viewer and 
give the image a more smoothed appearance. However the image detail will be reduced when 
viewing at a small scale (zoomed out). 

 

8. You will be returned to the Import TIFF menu. Click OK to start the import process. 
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9. Open the imported map in a new viewer. Zoom and Pan around the map. Notice how quickly 
the image updates, this is due to the pyramid layers, that were created during the import. 

 

10. We now to add the projection information to the image. Go to View >Layer Info or to 

shortcut click . Steps 10-13 can be skipped if using version 8.6. 

 

You will see from the ImageInfo dialog box that in the Map Info section the pixel size and 
defining co-ordinates are present but the units are missing and there is no information in the 
Projection Info Section. 

 

 

 
 

10. From the Image Info dialog box click Edit > Change Map Model. Specify Meters in the 
Units drop down menu and Transverse Mercator in the Projection menu. Click OK and 
confirm Yes. 

 
11. Go to Edit > Add/Change Projection. Click the Standard tab and from the Categories menu 

choose United Kingdom and highlight British National Grid. 
 

 
 
12. Click OK. Confirm Yes when the attention dialog box appears. The projection information will be 

added to the image.  Close down the ImageInfo dialog box. 
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13. In order to update the projection information within the file, we need to close down nc21sw.img 
and reopen. 

Remove st21nw.img from the viewer using the Close Top Layer shortcut  
 
14. To be able to see the underlying image when we overlay the map, we need to make the white areas 

of the map transparent, while keeping the black areas opaque. 
 
This time we will be opening the image as a pseudo colour layer. Go to File > Open >Raster 
layer and select st21nw.img. Before you click OK, go to the Raster Options tab at the top of 
the dialog box. From the Display as: drop down menu select Pseudo Colour Layer. 
 

 
  

Images are usually only opened as pseudo colour layers if the data is discrete (e.g. a classified 
image) rather than continuous (e.g. a satellite image). It allows us to manipulate the colour and 
the opacity of the image. 
 
Click OK 
 

15. From the viewer go to Raster > Attributes, this will open the Raster Attribute Editor 
 

 
 

Change the Opacity of the white pixels to 0, by clicking and editing the bottom right hand cell 
of the table. This will make these pixels transparent. 
 
Click on the black filled cell in the Row 0 Colour column and change the colour to red. 
 

16. Go to File > Save to save the changes or shortcut by clicking . Now close the Editor  
 
17. In the same viewer as the map open the air photo mosaic 

(E:\ERDAS_Training\Examples\Viewer\assynt_photo_mos.img). Arrange the layers so that the 
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map is on top. Start the Inquire Cursor and type in X: 223130 and Y: 912243. Zoom into 
1:6000 scale using the Scale Tool, and explore the image. 
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Importing and Exporting – 3. Importing and Overlaying Vector Data 
 
In this exercise you will import DXF Ordnance Landform Profile contours from the BGS corporate 
holdings and display them over the airphoto mosaic. 
 

1. Click the Import/Export button on the IMAGINE Icon Panel  

 
2. From the Import/Export menu ensure that the Import option is toggled and 

select the file Type: as DXF to Coverage, from the drop down menu. Now 
change the Media: to File. 

 

Specify the Input File as nc21sw.dxf  (path E:\ERDAS_Training\Examples\Import_Export\) 
and the Output File as nc21sw to the same directory. Click OK. 

 

The Import DXF dialogue box will open (as shown below). Ensure that the defaults are 
unchanged. Then click on OK to start the import. 
 

 
 
Two folders forming an ArcInfo coverage will have been created in the Training folder, one called info 
and the other called nc21sw. 
 

3. Open the airphoto mosaic from 
E:\ERDAS_Training\Examples\Viewer\assynt_photo_mos.img into a Viewer. 

 
4. In the same viewer Go to File > Open >Vector Layer and select nc21nw. The 

contours will appear as black lines over the airphoto. 
 

5. The contour line style (e.g. colour) can be altered using the Vector Properties 

icon tool  accessible through the tools icon  in the viewer. 
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2 Module 3 - Subsetting 
 
This module assumes knowledge of: 

 

- Imagine Viewer 

 

Subsetting allows the amount of date we are working with to be minimised by specifying a particular 
geographic area. By working with data that has a smaller file size it allows faster processing and 
display updates.  

 

The Landsat mosaic of the Assynt area will be subset, producing a smaller size file for draping in the 
Virtual GIS module. 

 

1. In a new viewer open Assynt_6band (path E:\ERDAS_Training\Viewer) 

 

2. Go to Utility > Inquire Box or Right click with the mouse and select Inquire Box. 

 

With the left mouse button, click and drag the red inquire box, you will notice the co-ordinates 
changing in the inquire box menu. 

 

 
 

3. Specify the following area by typing in the co-ordinates in the inquire box menu: 

 

ULX 211000 LRX 242600 

ULY 927400 LRY 903100 

 

Then click Apply 

 

The inquire box will have reshaped to fit these co-ordinates. Do not worry if the value of the 
co-ordinates have changed slightly. This is due to the inquire box snapping to the pixels of the 
pyramid layers, and is acceptable in this task. 
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4. Click the Data Preparation button from the IMAGINE toolbar  and select Subset 
Image. 

 

5. The Subset Dialog Box will open. Specify assynt_6band.img as the input file (path 
E:\ERDAS_Training\Viewer) and assynt6_band_sub.img as the output file (path 
E:\ERDAS_Training\Viewer). 

 

6. In order to update the subset definition co-ordinates from the inquire box click the From 
Inquire Box Button.  

 

Note that if an exact subset is required the co-ordinates of the area can by typed directly in 
here, by-passing the inquiry box stage. 

 

 

 
 

7. To run the subset click OK. 

 

8. Once the process has completed open the subset in a new Viewer 

 

The process of subsetting a raster image is more streamlined via the GLT. The subset tool  in 
the ‘General’ portion of the window automatically opens the Inquire Box tool and Subset Definition 
dialogue. 
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Another approach to reduce the file size of an image is to save it in MrSID format. MrSID is a type of 
wavelet compression that can reduce file size by 10 to 20 times without noticeable loss of detail and the 
resulting files are compatible with most GIS software. As well as being able to display MrSID images, 
IMAGINE also allows images of 50million pixels or less to be saved as MrSID format. 

 

We will now use MrSID to compress the subset we have just created 

9. Click the Import/Export button from the IMAGINE icon bar.                                 

 

10. When the Import/Export menu opens, toggle Export and select the file type as MrSID. 

 

11. Select assynt6_band_sub.img as the input file (path E:\ERDAS_Training\Viewer) and 
assynt6_band_sub_sid.sid as the output file. Click OK. 

 

 
 

12. When the MrSID Compress window opens, change the layers to 321 RGB combination and 
set the compression ratio to 10 (this will give a compression ratio of 10:1). Click OK 

 

 
 

13. Open the compressed image and the original image in separate viewers  

 

You may need to save the breakpoints from the original image and then apply them to the 
compressed image to achieve similar contrasts. 
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14. Use Windows Explorer to compare file sizes between the two images. 

 

15. Geo-link the viewers by right clicking in one and selecting Geo. Link/Unlink and then left 
clicking in the other viewer.  

 

How do the images compare? 
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3 Module 4 - Mosaicing Images 
This module assumes knowledge of 

 

- ImagineViewer 

- Band combination manipulation 

- Breakpoint editing 

 

Satellite imagery or airphotos that are georeferenced or orthorectified and have an overlapping area can 
be stitched together to create a seamless mosaic. Mosaics allow easy viewing of large areas, but the 
increase in file size will reduce the refresh rate during panning. Typically, mosaiced images are 
compressed or subset into tiles for use in a GIS or printed as fieldslips. 

 

Mosaicing two georeferenced satellite images 

 

To demonstrate the mosaic tool we will be using subsets from two georeferenced May Landsat 7 
Images of the Shin Loch area of Scotland. 

 

1. In a new viewer Open E:\ERDAS_Training\Mosaic\206_19_subset.img and 
E:\ERDAS_Training\Mosaic\206_19_subset.img. Ensure that the images are opened with a 
321 RGB combination, with stretch and a transparent background. 

 

The images have different contrasts and the overlap line can clearly be seen. The aim is to 
produce a mosaic with a consistent contrast and a smooth transition across the overlap area. 
There are several ways of doing this, one of which will be shown here. 
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Decide which image has the better contrast (use Utility > Swipe to switch between the 
images). Make sure that the image that you have chosen is the top layer (View > Arrange 
layers) and open the Breakpoint Editor to manually match the contrast between images. 

 

Save the breakpoints in E:\ERDAS_Training\Mosaic\original_breakpoints.cbp, these will be 
applied later to the mosaic that is created. 

2. Click the Data Preparation button on the IMAGINE Icon Panel.                                   

 

3.   Select Mosaic Images from the data preparation menu and the mosaic tool viewer will open. 

 

Overlap line
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The mosaic tool has three modes, which are worked through progressively. Some of the icons 
displayed in the mosaic tool viewer will change depending on the mode. By default the Set 

Mode for Input tool is selected,  which allows the input files to be selected. 
 

4. To specify the images to mosaic go to Edit then Add Images. This can shortcut by going to 

. 

 

5. Once the Add Images dialog box has opened select E:\ERDAS_Training 
\Mosaic\206_19_subset.img as the image filename and toggle on the Compute Active Area 
button. 

 

 
 

6. Click the Set button and from the Active Area Options dialog box specify the boundary 
search type as Corner, then click OK. 

 

Icons used to 
select the three 
modes 
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With an image that has an irregular boundary it is common to find black pixels surrounding 
the edge, effectively making the image square. These pixels need to be excluded from the 
mosaicing process, resulting in an ‘active area’ of useful data. The search will define the 
active area by ignoring pixels with a low DN value. In this case we are using the default of 0. 

 

7. Click Add and the image outline will be displayed in the Mosaic Tool Viewer. Also add  
E:\ERDAS_Training\Mosaic\ 206_19_subset.img 

 

The outlines of both images should now be displayed in the Mosaic Tool Viewer 

 

 
 

8. In order to obtain a similar contrast between the two images the contrast matching option can 
be used. This will hopefully remove obvious contrast variations in the final mosaic.  From the 
Mosaic Tool Viewer go to Edit then Image Matching, or to shortcut click the Display 

Image Matching Options icon . The Matching Option Dialog box will open. 
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9. Toggle the For All Images option and click OK. 

 

10. We are now ready to define how the images will intersect. Select the Set Mode for 

Intersections icon  from the Mosaic Tool Viewer. The cutline icons will now be 
displayed. A cutline can be thought of as a line which defines the point where the use of data 
from one image ends and where the use of data from an adjacent image begins. 

 

 
 

11. Click the Set Default Cutlines for Intersection icon . Default cutlines will be generated 
within the viewer.  

 

Cutline icons 
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12. From the Mosaic tool go to Edit > Set Overlap Function, or go to shortcut . Here we 
define how the images will intercept. Click the Cutline Exists option and the Cut / Feather 
function and then Apply. The feather function grades one image into another, smoothing the 
transition. Close the dialog box. 

 

 

 
 

13. We are now ready to define the output mosaic. Select the Set Mode for Output Images icon 

 from the Mosaic Tool Viewer. Go to Edit > Output Options or go to shortcut . 
Ensure that the output pixel size is 30m and then click OK. 

 

14. Go to Process > Run Mosaic.  A Run Mosaic dialog box will open. In the Input File Name 

text box click on the folder icon  and type the filename mosaic.img in the following 
location: E:\ERDAS_Training\Mosaic\ 

 

 

 
 

 The Stats Ignore Value checkbox should be toggled and the value set to 0. Click OK 
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15. Open the mosaic in a new Viewer. The contrast of the image will appear too high, this is 
because a default stretch has been applied to the image. 

 

Start the Breakpoint Editor and load the breakpoints that you saved earlier. 

 

Take some time to inspect the mosaic, can you identify the seamline? 



 

 

 

40

4 Module 5 - Reprojecting Image Data 
 

This module assumes knowledge of: 

 

- Viewer 

 

It is a commonly required task to reproject image data from one projection system to another.  Imagine 
allows data in one projection system to be overlaid with data from a different projection system, by 
recalculating ‘on the fly’. However other software such as ArcView requires data to be in the same 
projection system. In this module we will reproject data into British National Grid (BNG). 

 

1. Open E:\ERDAS_Training\Mosaic\mosaic.img and open the ImageInfo dialog box.  

 

2. What Projection and datum does the image have? 

Close the image info window. 

3. Click the Data Preparation button on the IMAGINE Icon Panel.                               

 

4. Click the Reproject Images button and select mosaic.img as the Input File. Specify 
E:\ERDAS_Training\Mosaic\mosaic_reproject.img as the output file. 

 

5. In the Categories drop down menu choose United Kingdom and make sure that the 
Projection is British National Grid and the Units are meters. Click OK. 
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6. Once the process has run open the image in a new viewer and the ImageInfo dialog box to 
confirm that the image is now in Transverse Mercator projection with an Ordnance Survey 
1936 Datum. 

 
 

Q. How does this process differ from Stage 10 of “Importing and Exporting – 2. Importing and 
Overlaying Raster Map Data” on page17? 
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5 Module 6 -Geometric Correction 
 
In this module we will be using the geometric correction capability in IMAGINE to geocorrect a 
Landsat 7 panchromatic band that has a 15m-ground resolution of the United Arab Emirates. The 
panchromatic band will be georeferenced to a certain extent based on ephemeris data but this can be 
improved by taking ground control points (GCPs) from maps and then resampling the image based on a 
polynomial transform. 

 

1. In a Viewer open uae_pan_togeo.img (path E:\ERDAS_Training\Examples\Geocorrect). This 
is the Landsat Panchromatic image that will be geocorrected.  

 

2. In the same Viewer open uae_maps_for_geocor.sid (path E:\ERDAS_Training\Examples\). 
This is a mosaic of three maps from which we will be collecting GCPs and can be thought of 
as the reference image.  

 

3. Use the Viewer Swipe (Utility > Swipe) to examine how the images overlay. 

 

There is a noticeable offset between the two images. 

 

4. Remove uae_maps_for_geocor.sid from the viewer and open in a separate viewer. 

5. Click the Data Preparation button from the IMAGINE toolbar  and select Image 
Geometric Correction. 

 

6. The file to be geocorrected will now be chosen. From the Set Geo Correction Input File 
menu, ensure that the From Viewer option is toggled and click Select Viewer. 

 

 

 
 

 

7. Follow the on screen instructions and left click in the viewer containing uae_pan_togeo.img. 
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8. The Set Geometric Model window will open. Set the Geometric Model to Polynomial and 
then click OK 

 

9. The Polynomial Model Properties menu will open along with the Geo Correction Tools. The 
polynomial models is defined by the GCPs that will be collected. 

 

 

 
 

 
 

Select the Projection tab from the Polynomial Model Properties Menu and click the Set 
Projection from GCP Tool button. 

 

10. The GCP Tool Reference Setup menu will open. This menu allows us to choose which map or 
image from which we will be collecting reference control points. Make sure the Existing 
Viewer option is toggled then click OK. 

 

Polynomial Model Properties
Menu 

Geo Correction Tools 
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11. When prompted left click inside uae_maps_for_geocor.sid. 

 

12. The Reference Map Information window will open. This gives us information regarding the 
projection system of the image we are collecting GCPs from. Click OK. 
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13. A Number of Windows will open up, giving the general setup for collecting GCPs. 

 

 

 

Close up of
input image Close up of

reference 
image 

GCPs will be collected 
from the reference image 
from these two windows 

GCPs will be collected
from the input image
from these two
windows 

This white box can
be moved around
the image and
controls the area
visible in the close
up view 

This window,
shows the GCPs
collected and any
errors present 
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14. In order to GeoCorrect the panchromatic band we need to find points that we can identify on both the 
reference map and the image. Non-dynamic features such as road intersections, or edges of large buildings 
make good GCPs as they are usually clearly identifiable and are generally constant over time. However in 
less developed areas, features such as bends in rivers or field boundaries may have to be used. 

 

Use the inquire cursor to zoom into the road junction at the approximate positions: X= 434231, Y= 
2805887 in the reference map window and X= 433800, Y= 2805880, in the window containing the 
panchromatic image. 

 

    

GCP 1      GCP 1 

 

15. In order to collect a GCP point the Create GCP button needs to be active on the GCP tool menu. Make this 
active now. 

 

 
 

16. Measure the point on both images by clicking with the left mouse button. You will have to reactivate the 
Create GCP button after the first measurement. It does not matter if you measure the point on the input or 
reference image first. 

 

To reposition a point that has already been placed, click the Select GCP button from the GCP Tool and 
drag the point to its new location.  

 

Notice how the co-ordinates have been automatically entered into the GCP Tool table. 

 

17. Now identify and measure the following GCPs in the same way 
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GCP2 X=434139, Y=2767062 GCP2 X=434143, Y=2767123 

  
GCP3 X=429180, Y=2777989  GCP3 X= 429527, Y= 2778332 

 

  
GCP 4 X=427654, Y=2794902 GCP4 X=427777 Y=2794879 

 

When you measure the GCP4 on you will notice that IMAGINE predicted the location of the second point 
that was measured. This is a useful guide to positioning but should not be relied upon. 

 

After the 4th point has been measured the Residuals and RMS values will be shown, these are measures of 
accuracy. The accuracy of the measured points can be calculated as only three points are needed to solve 
the polynomial, with the fourth point being assessed against these. In terms of residuals, this assessment is 
made by calculating the distance (X or Y) between the source co-ordinate and the retransformed co-
ordinate based on the polynomial equations. 

 

The RMS for the point can be through of as the combined X and Y error. 

 

The relationship between residuals and RMS error per point is shown in the diagram below. 
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From ERDAS IMAGINE On-Line Help Copyright (c) 1982-1999 ERDAS, Inc. 

 

The residual and RMS values are pixel measurements. Therefore, an RMS of 2 equates to 2 x 15m (the 
pixel resolution of this image) i.e. 30m possible error. 

 

18. At this point it is recommended that that co-ordinates that have been collected are saved, in case you 
accidentally shut down the GCP tool. From the GCP Tool go to File > Save Input As and type in the file 
name as input.gcc (path E:/ERDAS_Training/Examples/GeoCorrect/). Also save the points collected from 
the reference image: File > Save Reference As and type the file name as reference.gcc. 

 

19. Continue to collect 10 more points, making sure that you have a good spread of points across the image. 
Save the points every so often. 

 
20. Try to reduce the RMS values so that they are less than 5 pixels for each point. However it is not worth 

positioning a point, in order to get low errors, if it is placed in an incorrect location as this will only lead to 
the propagation of errors through to the final geocorrected image. It is more important for the point to be in 
he right place than to get low residuals or RMS values.  Start by re-observing the points that have the 
highest value in the Contribution column. 

 

21. Once you are happy with the accuracy of the solution save the reference and input points and from the Geo 

Correction Tools dialog box click the Display Resample Image Dialog button.  

 

22. When the resample dialog box opens, type in the output file as uae_pan_geocorrected (path 
E:/ERDAS_Training/Examples/Geocorrect) and click OK. The image will be resampled based on the 
control points that have been measured. 

 

23. Close down all the viewers and geocorrection tools. When you are asked to save the current Geometric 
Model click No. 

 

24. Open the geocorrected panchromatic image and the map in a new viewer. Again use the Viewer Swipe 
function to assess the accuracy of the geocorrection. 
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6 Module 7 - Filtering 
 

Filtering is a form of image enhancement and is a method of increasing the amount of information that can be 
extracted from a given image. There are two main classes of image filters: low pass and high pass. A low pass filter 
will smooth an image by removing high frequency pixel value variations across an image, whereas a high pass filter 
will retain this high frequency variation, but remove low frequency variations. A high pass filter will therefore 
enhance edges and ‘sharpen’ an image.  

 

In this module we will experiment with a number of filters on the panchromatic band of a Landsat 7 Image. This 
image was acquired during the winter under hazy conditions; since the panchromatic band covers a wide region of 
the visible spectrum it is particularly susceptible to atmospheric haze. Filtering is one of the techniques that can be 
used to reduce the effects of the haze by increasing contrast along tonal boundaries. 

 

1. In a viewer open solway_filter_pansubset.img (path E:\ERDAS_Training\filter). You will see that the image 
has a ‘speckle’ like appearance. We are going to use the filtering tools to remove this ‘speckle’. 

2. From the viewer toolbar go to:  Raster | Filtering | Convolution Filtering. The dialog will open: 

 

 

 
 

3. From the list under ‘Kernel’ select the 3x3 Low Pass filter.  

 

For a low pass filter the 9 cells of the matrix all contain the value of 1 e.g.  

 

1.0 1.0 1.0 

1.0 1.0 1.0 

1.0 1.0 1.0 

 

When passed over the image each pixel is multiplied by each of the values in the matrix, if adjacent pixels have 
similar values then the relative difference will remain small after filtering, however if adjacent pixels have a larger 
difference in values then the multiplication by the filter values has the effect of reducing this difference by averaging 
out the pixel values. The filter is therefore averages out larger variations and  ‘passes over’ small variations. 
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4. Before applying the filter to the image the user needs to decide weather they wish to permanently apply the 
changes brought about by the filter by using the ‘Whole Image’ option at the bottom of the dialog, apply it to a 
specified area of the image using an AOI, or just apply it to the image while they are working it using the ‘On 
Demand’ option. In this case we will apply it to the ‘Whole Image’ so select this option. 

5. The image should now look smoother. Save the new image by selecting File | Save | Top Layer As from the 
Viewer toolbar. Save it to E:\ERDAS_Training\filter\Solway_lowpass. 

 

We will now experiment with a few other filters to see their effects: 

 

6. Re-open the original image as in step 1 above. 

7. From the kernel menu in the convolution filtering dialog select the 3x3 High Pass filter, this time apply the 
filter on demand. 

 

A high pass filter has the opposite effect to the Low Pass filter and so highlights features with a high spatial 
frequency. Although the image now has a more ‘speckle’ like appearance, features such as roads and fence lines are 
easier to interpret. The matrix for a high pass filter looks like this: 

 

-1.0 -1.0 -1.0 

-1.0 9.0 -1.0 

-1.0 -1.0 -1.0 

 

The inclusion of a high value in the centre ensures that the high spatial variations are enhanced. 

 

This area is famous for its glacial features, and we are going to interpret these later. It would therefore be useful if 
we could filter the image to enhance such features. From a preliminary examination of the imagery we can see that 
these features trend in a NE – SW direction. To do this we need to choose the appropriate filter.  

 

8. From the Kernel list in the convolution filtering dialog select the 3x3 Right Diagonal Edge Detection 
filter. This filter has the following matrix: 

 

-2.0 -1.0 0.0 

-1.0 0.0 1.0 

0.0 1.0 2.0 

 

This filter has been designed to highlight NE-SW trending edges, the three zero values run in this orientation and so 
no change will be made to pixel values in this orientation. However the matrix values in the upper left region of the 
filter are all negative – this has the effect of decreasing values on the NW side of the edge. The positive values on in 
the lower right have the opposite effect and so increase values to the SE of the edge; the combined effect is therefore 
to highlight NE-SW trending edges. 

 

9. Apply this filter to the Whole Image, and save the results to E:\ERDAS_Training\filter\ 
Solway_diag_edgedet.img. Analysis of the image indicates that some of the edges of the glacial features have 
been enhanced, however there are other edges (such as roads and fence lines) that have a similar orientation and 
so have also been enhanced. We will use this image later on the help digitise the crest lines of the Drumlins, but 
we will need additional sources of data. 
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Opening DTM data in the viewer 

 

A very useful data source for the interpretation of surface features is Digital Terrain Models (DTMs). In Imagine 
there are a number of options that can be chosen when opening a DTM; these control how the DTM is displayed. In 
this exercise we will learn how to open the DTM as a greyscale image or as a shaded relief image. The relief display 
tends to be easier to interpret and has the advantage of allowing the user to explore different angles of shading. 

 

We are going to use a CEH DTM. We will experiment with different sun angles, and then use the DTM, a 3 band 
false colour image of the area and the Solway_diag_edgedet.img you have created to digitise some of the drumlins 
in the Solway area. 

 

10. In a new viewer navigate to File | Open | Raster Layer find the file Solway_DTM.img in the training folder. 
Highlight the file and click the Raster Options tab at the top of the dialog. Accept the defaults and click OK. 

 

The DTM will display as a greyscale image; higher areas appear brighter. 

 

11. Keep this viewer open, open a new viewer from the main IMAGINE tool bar. 

12. In the new viewer repeat step 10, this time under the Raster Options tab select Relief for display as, and click 
OK. 

 

13. In the second viewer select Raster | Relief Shading Tool, a dialog will open: 

 

 
 

This tool allows you to choose how the DTM is displayed. The scale box increases the amount of detail shown in the 
display – it is recommended to increase this figure above 5. 

 

Different lighting conditions will reveal different features. Three factors control the lighting; the Suns Azimuth, 
Elevation and the Ambient brightness. Moving the dot in the concentric circles controls both the Azimuth and 
elevation; if the dot is moved to the centre the sun would be directly overhead, therefore no shading will be provided 
to the relief so the image appears white. A similar situation occurs if the dot is moved right to the edge of the circles, 
in this position no sun reaches the relief at all (rather like night time) and so the image appears completely dark. 
Good elevations to use tend to lie around 45º since this provides maximum shading and so maximum relief effects. 

 

Moving the dot around the circles controls the suns azimuth (the angle from which the light comes). This is useful as 
it reveals how a feature will look when illuminated from different angles. 

 

14. Experiment with the controls within the relief tool to gain an understanding of their effects. 
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15. Once you have an understanding of these create an image which is illuminated from the SW (Azimuth ~ 220º) 
with a good scale. Go to File | Save | Top Layer As choose a suitable file name such as Solway_DTM_SW.img 
and save it to the E Drive. 

16. Repeat step 15 but this time shade it from the SE. We will use both of these images for our interpretation. 

 

Interpreting glacial features in the Solway area 

 

For this exercise we are going to interpret one type of glacial feature, namely the drumlins located to the south of the 
Solway Firth. We will use the 2 shaded DTMs, filtered image and a colour Landsat image as the four data sources. 

 

17. Open 4 viewers from the ERDAS IMAGINE main tool bar. 

18. Open your shaded relief images in two of the viewers, and the filtered image you produced earlier in the third. 
In the fourth viewer open the image Solway_Lsat5_457.img, a false colour Landsat 5 image of the area. 

19. It is good practice to link the viewers together to ensure easy navigation, before doing this go to the main 
IMAGINE tool bar, select Session | Tile Viewers to get all four on the screen. 

20. Right Click in the first viewer and select Geo. Link\Unlink, now Left Click in the second viewer to link it to 
the first, repeat this for the other two viewers so that all four are linked. 

 

We now need to create a vector layer onto which we can digitise the crestlines of the drumlins. 

 

21. Make the viewer containing the false colour image the active window and from the Viewer menu select File | 
New | Vector Layer, a dialog as shown below will open. Locate the E drive directory and save the file as a 
Shapefile : Solway_drumlins.shp. 

22. Set the Shapefile type to  Arc Shape. 

 

 
 

23. The vector tool pallet will open automatically. 
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24. To digitise a crestline, first locate one from one of or all four data sources. Then in the viewer with the vector 

layer, select the  tool from the vector tool pallet, left click at the start of the crestline, click once where you 
want to change line direction, and double click where you want the line to end. Repeat the process for each 
crest, ensuring to save the work as you go. 

25. If you make a mistake, select the arrow tool from the vector tool pallet, click on the line to select it and then use 
the scissors on the tool pallet to remove the selected line. 

26. You may want to change to appearance of the lines to make them easier to see against the backdrop; from the 
viewer menu Vector | Viewing Properties, this opens a dialog: 

 

 
 

 

27. You are digitising Arc’s, therefore to change the properties of these; click on the little notebook next to the line. 
Selecting ‘other’ from here gives a number of options for changing the line style and colour. Yellows and 
Cyan’s tend to work quite well on the 457 false colour images. 

28. When the colours etc have been chosen you will need to click apply then apply again, you will then be 
prompted to save the style to a file for later viewing, if you wish to do so give it the same name as the vector 
file. 
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Note: Rather than displaying each image in a different viewer, you can display them all in one viewer and 
rearrange the order in which they are displayed. 

 

 

 

 



 

 

 

55

7  Module 8 - 3D Visualisation in Virtual GIS 
 
This module assumes knowledge of 

 

- ImagineViewer 

 

Virtual GIS is a 3D-visualisation tool, which allows the integration and manipulation of DEMs, vector and raster 
layers. Flood layers and fly-throughs movies can also be created. In this module we will explore the main functions 
of the tool. The use of VGIS can be divided into three areas: 
 

• Part 1 DEM manipulation 

• Part 2 Draping raster and vector layers 

• Part 3 Basic fly-through generation 

 

Virtual GIS – Part 1 DEM Manipulation 

1.  Click the Virtual GIS button on the IMAGINE icon panel                                                

Select VirtualGIS Viewer from the VirtualGIS menu and a blank VirtualGIS Viewer will open (see 
figure on next page). 

 

This viewer operates in a similar way to the normal 2D viewer but has some additional functions. 

 

2. To display a DEM click on File > Open > DEM and navigate to E:\ERDAS_training\Example\VGIS and 
select assynt_20m_dem.img. The DEM must be in .img format. Click OK. 

 

A perspective view of the DEM will display in position mode at low resolution. The DEM displayed has 
been generated from aerial photography and covers the Assynt area. 

 

3. There are six navigation modes available for moving around the model. They are available from a pull 
down menu at the right hand side of the window. When set to Target Mode (a red cross will appear on 
screen) moving the mouse with the left button continuously depressed will enable the model to be rotated 
and tilted around the red marker. To change the location of the marker simply double click (left mouse 
button) somewhere else on the model. When set to Position Mode the model can be moved without 
rotation about any point. Using both of these modes is sufficient to navigate to any position on the model 
and view it from any angle. To zoom in or out of the image, hold the middle mouse button down and move 
the mouse either away from you or towards you. If you ‘lose’ the model simply click on Fit scene to 
window to refresh the screen and redisplay the model. [The mouse settings may need to be adjusted in the 
control Panel so that the middle mouse button is set to ‘middle mouse button’ and not scroll.] 
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You might want to also try the Dashboard, Selection and Terrain following mode (joystick is unavailable…) 

 

4. The DEM is currently displayed at low resolution; this is ideal for moving around the model. The detail 
shown by the model can be increased by going to View > Level of Detail Control. 

 

Unless a high spec graphics card is installed in the PC, it is advisable to navigate to the desired view while 
in low level of detail, and then to increase the amount of displayed data. Note that the DEM and raster 
layers can be edited independently. 

 

 

 
 

Increase the DEM LOD (%) to 40. Click Apply. Wait until the viewer updates (this may take a few 
moments) and then click Close. Notice the extra information that is revealed. 

 

5. Altering the lighting conditions of the model, is a useful way of bringing out information within the DEM, 
such as drumlins or striations. 

 

Click on View  > Sun Positioning.  

 

 

Navigation Modes (this
will be a pull down
menu in some versions
of VGIS) 

Fit scene to
window 

 
Position mode 

Target mode 

Navigation mode 

Terrain following
mode 
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The Azimuth, Elevation and Ambience can be altered by clicking and dragging the pointers left and right. 
A quick way of changing the Azimuth and Elevation is by clicking and dragging the black dot around the 
‘target’. 

 

Experiment with various sun positions. 

 

6. Most of the model manipulation takes place in the Scene Properties dialogue box, found under View. This 
can be used to change the vertical exaggerations, motion speed, model colour, background type (e.g. a 
cloudy sky or night sky), add fog etc. and to generally add ‘realism’ to the model. 

 

Explore the various options, try increasing the vertical exaggeration, introducing fog, changing the terrain 
colour and adding a fade colour background. 

 

 
 

Virtual GIS – Part 2 Draping raster and Vector Layers 

 

1. Raster imagery in greyscale, true colour or pseudo colour can be draped onto the 3D model as long as they are 
projected to the same co-ordinate system. The raster file is selected by navigating through File > Open > 
Raster Layer. 

 

Navigate to E:\ERDAS_Training\Examples\VGIS\ and open the file Assynt_6band_sub.img as a True 
Colour 321 image. The Landsat image will be draped over the model. 

  

 Try different levels of detail for the raster overlay and the DEM. 

 

2. Repeat the process and drape over assynt_1923_geol_geo_v2.sid from the same directory. This is a 
geocorrected geological map of the area. 

 

3. Ideally we would like to see both the geology and the satellite image simultaneously to explore the relationships 
between the relief and the two raster layers. In order to do this we can blend the two layers. 

 

Go to View > Arrange layers and drag the Landsat image so it is above the geology raster by clicking and 
dragging with the left mouse button. Select Apply. 

 



 

 

 

58

 
 

4. Go to View > Blend (8.4) or Utility > Blend (8.5) and set the Blend Fade to 50%. 

 

Zoom in experiment with different blend percentages. 

 

5. Remove the geology layer before we add the vector layer 

 

Navigate through View > Arrange Layers, and right click on the geology raster in the Arrange Layers 
dialog box. Select Delete and then Apply the changes. 

 

(It maybe necessary to reset the blend percentage to 100% if the image appears dark) 

  

6. IMAGINE will display ArcInfo coverages and ArcView shapefiles without the requirement to import them. 
However, there are a number of bugs when displaying shapefiles, therefore it is often preferable to import 
these prior to draping. ERDAS uses ArcInfo coverages as its native format, along with ‘annotation layers’, 
‘overlay layers’ and ‘areas of interest’ files.  

 

To display the vector file navigate through File > Open > Vector, and choose the arc coverage file 
E:\ERDAS_Training\Examples\VGIS\geol_lines. 

 

ERDAS will compute a drape file (*.drp). Sometimes sections of linework are hidden under the 3D model 
and in these cases it is advisable to offset the vector files from the terrain using the Layer Offsets tool in 
the View menu. 

 

7. Now we will create a flood layer within the viewer. As well as being a useful tool in flooding studies the flood 
layer can be used to study elevation changes across the model. 

 

Click File > New > Water layer. When prompted to enter a file name Navigate to 
E:\ERDAS_Training\Examples\VGIS\ give the filename flood.fld. Click OK. 
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8. A new menu header with the title Water will appear in the VGIS Viewer. Select on this header and click 
Fill Entire Scene. The water layer will be generated at a default height. 

 

9. To alter the elevation of the water layer navigate through Water > Water Elevation Tool. 

 

 
 

 By clicking and dragging the thumb wheel, typing in, or using the up/down arrows the desired elevation 
can be achieved. 

 

11. Also try adding clouds, mist, and various backgrounds etc. 
 
12. The flood layer etc. will be removed before we generate the fly through. Click the Close Top Overlay 

Layer  
 
13. When you have your model set up on screen, complete with raster/vector overlays as desired, you can save 

it as a VirtualGIS project which will save you from reconstructing the model and overlays each time. Save 
the project now. 

 

Select File > Save > Project As. Navigate to E:\ERDAS_Training\Examples\VGIS and save the project as 
assynt_3d.vwp. 

 

Virtual GIS – Part 3 DEM Fly Through Generation 

 

1. The first stage in producing a fly through is to digitise a flightpath. 

 



 

 

 

60

Click Navigation in the VirtualGIS viewer and select Flight Path Editor. The Flight Path Editor 
window will open. 

 

 
 

2. Flight paths are digitised from a normal 2D viewer. Open the file Assynt_6band_sub.img (path 
E:\ERDAS_Training\Examples\VGIS), in a new viewer. 

 

3. From the Flight Path Editor select Utility > Digitise Flight Path 

 

4. The Viewer Selection Instructions window will open.  

 

 
 

Follow the instructions and click with the left mouse button in the 2D viewer containing 
Assynt_6band_sub.img. This will link the viewer to the Fight Path Editor. 

 

5. A Define Flight Path menu will open.  

 

 

 
 

Digitise a flight path in the viewer by clicking the left mouse button and defining a number of points. You 
may want to start initially with a simple circular flight path. Double click to end the path. 
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6. Now go back to the flight path editor menu. You will see that positional information has been taken from 
the digitised flight path, and has been added to the table, as well as some default altitude and attitude 
information.  

 

To apply these changes to the flight path, click the Add Changes to Flight Path Button  and the flight 
path will appear at the bottom of the menu.  

 

 
 

7. To start the flight click the Start Flight button .  

 

The flight may appear to be very slow. The smoothness and speed of flight is depend on a number of 
factors: 
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• The size of the VirtualGISViewer (a smaller viewer - faster). 

• The detail level of the DEM and overlays (lower detail – faster). 

• The flight speed (m/s) set in the Flight Path Editor (Higher speed – faster). 

• How powerful the PC is. 

 

Try altering the first three factors to achieve a reasonably fast flight. Don’t worry if it appears ‘jerky’ or if 
you need to reduce the level of detail significantly – we are really just making sure the flight path is 
reasonable. The flight will be smoothed out during the creation of the final movie and the level of detail can 
be increased to maximum just before the movie is generated. 

 

To return to the start of the flight path click the Reset to Beginning of Flight Path button   

To stop the flight click the Stop Flight button . 

 

After making any changes in the Flight Path Editor ensure that the Apply changes to flight Path button  
is clicked 

 

8. The Flight Path Editor table is interactive and the attitude and altitude information can be altered to achieve 
a more visually impressive or useful flight. Take to some time to experiment with the various options: 

 

• The flight path positional information can be altered most simply by moving the nodes of the flight 
path in the 2D viewer. This will change the X and Y positions in the Flight Patch Editor. If you are 
good with co-ordinates they can be typed in directly 

 

• To change the height (in m) of the flight change the Above Sea Level (ASL) or above Ground Level 
(AGL) edit the table values. 

 

• The Look Azimuth defines the direction you are looking from the plane. Zero is straight ahead, 90 
degree is directly to the right, 180 degrees is directly behind etc. 

 

• The Look Pitch defines where the nose of the plane is pointing, a negative pitch will be looking down 
and positive pitch looking up (a look pitch of –10 tends to work well). 

 

• The Roll defines the relationship of the plane to the horizon. A 45 degree roll will be a 45 degree roll 
to the right. 

 

• The Speed (in m/s) defines how fast the flight is, although this is generally not a true value as the 
power of the computer is also relevant. A value of 400 will work well on a slow machine, a lower 
value will be needed on a faster machine. 

 

• The focal point dictates where the viewer looks during part/all of the flight. 

 

9. Once you are happy with the flight, save the flight path by selecting File > Save As, and save as flight.flt 
(path E:/ERDAS_Training/Examples/VGIS/), in the Flight Path Editor. 
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10. At this point also save the Virtual GIS Project. Increase the level of detail of the DEM and raster overlay to 
maximum. In the Virtual GIS viewer go to File > Save > Projects as… Navigate to 
E:\ERDAS_Training\Examples\VGIS and save the project as assynt_3d.vwp.  Click Yes to overwrite the 
existing file. 

 

11. Close down all the viewers. 

 

12. In order to create a movie from the flythrough. Click the Virtual GIS button on the IMAGINE icon bar 
and select Create Movie. Select the Virtual GIS project and save the output movie as flight.avi in 
E:\ERDAS_Training\Examples\VGIS. Click OK. 

 

 
 

13. From the Video Compression window, select the Compressor as Microsoft Video 1 and click OK.  

 

 
 

The movie will now be generated, which may take a few minutes to create, depending on the length of your 
flight and the flight speed.  

 

If progress is very slow you may want to cancel the operation and increase the flight speed (e.g. 400), this 
will reduce the number of frames generated and speed up the creation of the movie. 

 

 
 

13. Using Windows Explorer to navigate to the location of the video and double click. The movie should open 
and play. 
 
If you have time, try improving your fly-through. 
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Module 9 - Creating Map Compositions 
 
Plots are produced in IMAGINE by creating a Map Composition which has the functionality to add tiles, scale bars 
and gridlines much as the Layout window works in Arc. 

 

In this module we will produce a map composition based on data from the Assynt area. A shapefile vector layer will 
also be created. 

 

1. From the IMAGINE icon tool bar select the Map Composer button                            

 

2. Select New Map Composition from the Map Composer dialog box 

 

 
 

3. When the New Map Composition dialog box opens type map_1.map as the New Name and specify the 
map width and height as 25 inches, the click OK. This will be the size of the composition. 

 

 
 

4. A Map Composer window will open together with an Annotation tool Bar. The main functions of the 
toolbar are shown below but please note there might be slight variations due to the version of Imagine that 
you are running. 
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5. In a normal IMAGINE viewer open assynt_6band.img (path  E:\ERDAS_Training\ Examples\Viewer) in a 
321 combination. 

 

6. To insert this image into the map composition click on the Create Map Frame button on the Annotation 

tool bar  and hold down the left mouse button to drag a rectangle in the map composer window. 

 

7. From Map Frame Data Source, click Viewer. 

 

 
 

 

8. Follow the Create Frame Instructions and click inside the viewer containing assynt_6band.img 

 

 
 

Various annotation 
tools for creating 
boxes, lines, arcs etc. 

Selection tool 

Insert text tool
Select map frame 

Create map frame Create grid 

Create scale bar Create legend 
Undo previous edit 

Tools for arranging
order of annotation
layers 

Change 
annotation style 
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9. The Map Frame dialog box will open. This menu is used to define the size, scale and position of the image 
within the map composition. 

 

 

 
 

You will notice that a white box has appeared in the viewer that was just selected. This defines the area of 
the image that will be used in the map composition. As we want to use the whole image click the Use 
Entire Source. The white box has now increased in size to incorporate the whole image. 

 

10. Now change the scale. In the box adjacent to Scale 1: type in 200000. 

 

11. The final stage is to define where the image will appear in the map composition. In the two boxes bellow 
Upper Left Frame Coordinates, change the values to X=2 and Y=22. This will position the image in the 
top left-hand corner of the composition. Click OK to insert the image. 

 

12. The next step is to create a grid over the image with co-ordinates around the edge. First click the Create 

Grid Ticks button on the Annotation toolbar  and the mouse icon will change to the select map frame 
symbols. Now click inside the image within the Map Composer window. 

 

13. The Set Grid/Tick Info menu will appear. This menu allows the spacing of the grid and the labels around 
the edge of the image to be defined. 

 



 

 

 

67

 
Change the Horizontal Axis spacing to 10000 meters and toggle on the Use Full Grid. This will give a 
grid line every 10km. To copy this to the vertical axis click the Copy to Vertical button.  

 

14. Click Apply then Close. Your map composition should now look like this: 

 

 
 

15. Open a new Viewer and add assynt_photo_mos.img (path E:\ERDAS_Training\Examples\ viewer). 

 

16. Inset this image to the map composition the same way as the previous image, but this time specify the scale 
as 1:125000 and the upper left coordinates as X = 3 and Y = 7. 

 

17. Add a full grid to the image, this time with a spacing of 5000m. 
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18. We now have a satellite image of the Assynt area together with an airphoto image. In order to show what 
area the airphoto covers, a shape file can be digitised then overlaid on the satellite image, in the map 
composer. 

 

Open both assynt_6band.img and assynt_photo_mos.img in a Viewer and arrange the layer to ensure that 
the assynt_photo_mos.img is the top layer. 

 
 

19. Go to File > New > Vector Layer. When the Create a New Vector Layer menu opens navigate to 
E:\ERDAS_Training\Examples\Map_composer and enter the file name as photo_mosaic_outline.shp. Click 
OK. Note: the ‘double image’ above can also be inset into the composer. 

 

20. From the New Shapefile Layer Option make sure the Shapefile type is set to ARC Shape and click OK. 

 

 
 

21. Click the Vector Tool Palette button  from the Viewer Tool Bar and then select the Close Polygon 
Tool. 
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22. Using the left mouse button digitise a square around the outline of the air photo mosaic. It doesn’t matter if 
it is not perfectly accurate. 

23. We now need to change the line properties to make it more obvious. Click the Show Vector Properties 
button from the Vector Tool Palette. 

 

 
 

24. Click on the Arcs properties button to change the line style, and click Other. 

 

 

Close polygon 
tool 

Show vector
properties 
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24. The Line Style Chooser menu will open. Change the Outer Colour to red and the Width to 2.5 pts. Then 
click OK 

 

 
 

25. When you are returned to the Properties for photo_mosaic_outline.shp menu, click Apply and then OK.  

 

The box you have digitised will now be red. 

 

26. We now want to update our map composition and overlay this shapefile on the satellite image. In order to 

do this without re-inserting the image click the Select Map Frame button  from, the map composition 
annotation tools and double click the satellite image in the map composer. 

 

27. A new viewer will open containing the satellite image and a Map Frame dialog box. In the new viewer, 
open the shapefile that you have just digitised and click OK in the Map Frame dialog box. 

 

 
  

 

The shapefile will be added to the map composition 

 

28. We now want to draw a red box around the airphoto mosaic actually in the map composer, to illustrate the 
link between the areas. 

 

29. Click the Annotation Styles button and then from the Styles dialog box click Fill Style button 
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30. From the Fill Style Chooser dialog box toggle off the Use Solid Colour dialog box and change the Use 
Outline to red 2.5pts. Click OK 

 

 

 
 

31. Zoom into the air photo mosaic in the map composition. From the Annotation palette select the Create 
Rectangle Annotation button. 

 

Annotation styles 
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32. Draw a box around the air photo mosaic, by clicking and dragging with the left mouse button. 

 

33. In a new Viewer navigate to E:\ERDAS_Training\Examples\map_ composer and open 
coast_in_polyline.shp. This is an OS Meridian outline of the UK coastline. 

 

34. In the same way as the other images insert the shape file into the map composition. Ensure the Change 
Scale and Frame Area option is toggled and the entire source is being used. Specify a frame width of 5.00 
and a height of 9.34 and the upper left frame coordinates should be set at X=16.50 and Y=19.50. 

 

 
35. With the fill style set to a blue outline, create a rectangle annotation, illustrating the approximate position 

of the area of the satellite image on the vector coast shapefile. 
 
36. We will now add scale bars to the images. Imagine calculates the scale automatically. From the 

Annotation toolbar palette, click the Create Scale Bar button . 
 
37. Click once directly below the satellite image. This is where the scale bar will be placed. 

 
38. Follow the instructions and click once in the map frame of the satellite image 
 

 
 

Create 
rectangle 
annotation 
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39. When the Scale Bar Properties Menu appears, Specify the Units as Kilometres and the Maximum 
Length as 5 inches. Then click Apply and  Close 

 

 
 
40. Position the tool bar, so it lines up with the grid as shown below. This can be done in the same way as you 

would move text. Be careful not to resize as this invalidates the scale. 
 

 
 
41. Add the  following text below the scale bar in an appropriate size  
 

• 1:200000 
 
42. Repeat the process for the air photo mosaic, again specifying a minimum size of 5 inches, and the 

following text: 
 

• 1:125000 
 
Useful tip: If you make a mistake and want to delete the scale bar, the best way to do this is to make it 
active and then use the Cut button from the Annotation palette. This also works for other annotation such 
as text, polygons and lines.  

 

43. We will now add titles and text to the composition. Select the Create Text Annotation button  from 
the Annotation toolbar, and click with the left mouse button at the top of the map composition 

 
44. Type in ‘Satellite and Airphoto Mosaic of Assynt’ and click OK 
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45. You will notice that the text appears very small. Double click on the text with the left mouse button. This 
opens the Text Properties dialog box. Here you can change various properties of the text such as 
positioning and size.  
 
Increase the size to 30 and click OK 
 

 
 
 

46. It is also possible to manually move the text and change its size. To do this the text need to be made active. 
Click once with the left mouse button. 
 
• To reposition click towards the centre of the text and drag, or use the directional keypad.  
• To resize click and drag one of the corner points. 
 
Experiment with both of these until the text has a size and position you like. 

 
47. Also add the following text to the map composition: 
 

• Under the satellite image:   Landsat 7 ETM mosaic of Assynt 
• Under the airphoto mosiac:  1:25000 air photo mosaic 
• Under the coastline image:  Copyright Ordnance Survey  
 
You may need to reposition the scale bars slightly. 
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8   Module 10 - Band Ratios 
 
Band ratioing is the process of dividing one band by another. This process will highlight a certain feature of the 
surface depending on its spectra in certain bands. 
 
The first step is to decide which features are to be highlighted. For Remote Sensing Geology we are often concerned 
with mineral exploration. Different minerals absorb and reflect different regions of the Electromagnetic Spectrum. 
Using devices such as the PIMA (Portable Infrared mineral Spectrometer) we can measure the spectra of a mineral 
sample to produce a graph such as that below. 
 

 
 
If we take the example of the Fe-Rich Schist above, we can see, that it has a high reflectance value for band 3 of 
Landsat and a low reflectance for band 1. Therefore a ratio of bands 3/1 will distinguish the Iron Oxide minerals. 
 
Other important band ratios are: 
• Landsat bands 5/4 for Ferrous minerals  
• Landsat bands 5/7 for clay minerals. 

 
It also possible to define your own band ratios for different minerals using spectra such as the ones seen above. 
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Important note. 
For band ratioing in ERDAS IMAGINE it is imperative that the data to be ratioed are in a floating data format (as 
standard Imagine images are in an unsigned 8-bit format). The first step to band ratioing is therefore to alter the data 
type. 
 

1. Open a viewer and use the image information icon  to open the image information for the file 
bif_subset.img (this is an extract from a Landsat ETM scene in Northern Mauritania) check if the data are in a 
‘float’ format: 

 

 
 
2. If as above, the data are not floating point then it is necessary to use the subset image process to alter the data 

type. If the data is already float then you can skip to point 7. 
 
3. Open the subset image process dialogue (DataPrep – Subset Image). 
 
4. For the input image enter the image which you wish to use for the ratio. 
 
5. For the output enter a file name. 
 
6. It is only necessary to alter the output data type to ‘float single’; all the other options in the dialogue can remain 

as the default. 
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7. Once the data are floating point, you can start the band rationing process. In Imagine it is possible to ratio bands 

from within the same image. From the main Imagine menu select the interpreter button, then utilities then 
operators. A dialogue as below will open: 

 

 
 
8. This dialogue allows mathematical operations to be carried out between different images or between different 

bands of the same image. 
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9. The input file number 1 and number 2 will both be the same floating data file created in step 6. However we 
need to specify the band (layer) for each image. For this exercise we will first carry out a ratio to reveal Iron 
Oxide. For input file 1 use the drop down menu below to specify band 3. For input file 2, specify band 1. We 
are therefore dividing band 3 by band 1. 

 

 
 
10. In the output options use the dropdown menu to specify “/” (division) as the operator. 

 
11. Enter a name for the output image and ensure that it is a floating data type. Click OK and the process will run. 

This will produce a single band image, which will be displayed as a greyscale image. In order to add colour to 
the image we need to specify two additional band ratios and then use the layer stack command to produce a 3-
band image. 

 
12. Carry out steps 7 to 11 for the same image, however now we want to produce a 5/7 (clay minerals) and a 5/4 

(ferrous mineral) ratio. 
 
13. Once all three images have been processed, use the interpreter – Layer Stack operation to stack the three images 

in the following order: 
 

• Input 1 = 5/4 Ferrous 
• Input 2 = 5/7 Clay 
• Input 3 = 3/1 Iron Oxide 

 
This will produce a three-band image in which all the ferrous minerals will appear as shades of red, the clay 
minerals as greens and the Iron Oxide minerals as blues, such as below: 
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Note: the ratios and mineral composite images described above can be made using the Indices option in Imagine 
version 8.6 and above. The process is available via Image Interpreter and Spectral Enhancement. 
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Appendix 1 
 

IMPORT/EXPORT FORMATS 

 

These file types may be read and written directly by IMAGINE 
(From ERDAS IMAGINE On-Line Help Copyright (c) 1982-1999 ERDAS, Inc) 

 

 

Extension Format Description 
.aoi HFA Area of Interest file - stores a user-defined area of interest.

.bil Binary ESRI Arc/Info & Space Imaging BIL raster file. 

.bip Binary ESRI Arc/Info & Space Imaging BIP raster file. 

.bsq Binary ESRI Arc/Info & Space Imaging BSQ raster file. 

.bmp  Windows bitmap 

.dt1 Binary DTED Level 1 & 2 

.ers Binary ERMapper format image file. 

.fit Binary Silicon Graphics image file format 

.gif Binary GIF format static image files, usually downloaded from
Web sites. The optional LZW Module is required to read
these files as GIF is based on the LZW compression
technique patented by Unisys. 

.gis ERDAS 7.x Thematic file - raster data 

.glt  Geospatial Light Table session file 

.img HFA Image file - stores single or multiple raster layers, contrast 
and color tables, descriptor tables, pyramid layers, and file
information. 

.jpg Binary JPEG File Interchange Format (JFIF) image files. 

.lan ERDAS 7.x Continuous file -raster data 

.map ASCII Map file - stores map frames created with Map Composer.

.ovr HFA Overlay file - stores an annotation layer which was 
created in a map frame, in a blank Viewer, or on an image 
in a Viewer. 

.png  Portable Network Graphic 

.pro Binary Plus3 TerraModel project layers - vector engineering 
drawings. 

.raw ASCII Header file used to describe the formatting of generic
binary data files to allow them to be used by the Raw 
format Raster DLL. Thus, most raster data in BIL, BIP or
BSQ file format can be accessed directly merely by
defining this simple header. 



 

 

 

81

.sdv  SDE Vector Layer 

.shp  ESRI ShapeFile 

.sid  MrSiD® Compressor 

.stk ASCII ESRI GRID Stack file 

.tif Binary Tagged Image File Format (TIFF) file, including
GeoTIFF raster file 

.trl  Snail Trail from Geospatial Light Table 

.vue ASCII Viewer View file - defines the configuration of a Viewer. 
These files are used to store and recall the exact size,
position, and content of a Viewer of map composition. 

 
File types that may be imported or exported through the IMAGINE Import/Export facilities 
 
(From ERDAS IMAGINE On-Line Help Copyright (c) 1982-1999 ERDAS, Inc) 
 
Import (If you are importing data into IMAGINE) 
 
ADRG    Select this option to import ARC Digitized Raster Graphics data from CD-ROM only.  
ADRI    Select this option to import ARC Digitized Raster Images data from tape only.  
ANT (ERDAS 7.x)      Select this option to import annotation ERDAS Ver. 7.5 and earlier data from file or CD-ROM. 
ARCGEN      This option applicable to the Vector module only. Select this option to import ARC/INFO GENERATE 

format files from file or CD-ROM. The  
Arc_Interchange to Coverage  This option applicable to the Vector module only. Select this option to import data in ARC 

Interchange format file or CD-ROM.  
Arc_Interchange to Grid    This option applicable to the Vector module only. Select this option to import data in ARC 

Interchange format file or CD-ROM.  
ASCII Raster       Select this option to import data in ASCII format from file or CD-ROM.  
ASCII To Point Coverage      Select this option to import data in ASCII format from file or CD-ROM to a point coverage of 

single or double precision  
ASCII To Point Annotation      Select this option to import data in ASCII format from file or CD-ROM to point annotation.  
AVHRR (NOAA)      Select this option to import NOAA Advanced Very High Resolution Radiometer data from tape, file, or CD-

ROM.  
AVHRR (Dundee Format)      Select this option to import Advanced Very High Resolution Radiometer data in Dundee format from tape.  
AVHRR (Sharp)      Select this option to import Advanced Very High Resolution Radiometer data in Dundee format from tape.  
 
CADRG (Compressed ADRG)  Select this option to import RPF frames that are distributed by the Defense Mapping Agency (DMA).  
CIB (Controlled Image Base)  Select this option to import RPF frames that are distributed by the Defense Mapping Agency (DMA).  
DAEDALUS       Select this option to load Daedalus AMS and ABS sensor data from 8mm tapes.  
USGS DEM       Select this option to import U.S.G.S. Digital Elevation Models from tape, file, or CD-ROM.  
DFAD      This option applicable to the Vector module only. Select this option to import Defense Mapping Agency 

DFAD vector data from file or CD-ROM.  
DGN (Intergraph IGDS)      Select this option to import an Interactive Graphics Design Software (IGDS) file (also called Intergraph 

Design File, or DGN file) into an Arc/Info coverage.  
DIG (ERDAS 7.x)      Select this option to import ERDAS Ver. 7.X DIG data from file or CD-ROM. 
DLG      This option applicable to the Vector module only. Select this option to import U.S.G.S Digital Line Graphs 

(vector) from file or CD-ROM.  
DOQ        Select this option to import Digital Ortho Quad (DOQ) data from tape, file, or CD-ROM.  
DOQ(JPEG)       Select this option to import JPEG-Compressed DOQ's from tape, file, or CD-ROM.  
DTED       Select this option to import Digital Terrain Elevation Data from tape, file, or CD-ROM.  
DXF To Coverage      Select this option to import AutoCAD Digital Exchange Files (vector) from file or CD-ROM.  
DXF To Annotation      Select this option to import AutoCAD Digital Exchange Files (vector) from file or CD-ROM into IMAGINE 

annotation file format.  
ERS      Select this option to import CEOS (Committee for Earth Observation Standards) images in the format 

established by the European Space Agency (ERS).  
ETAK      This option applicable to the Vector module only. Select this option to import MapBase digital street network 

files (vector) from file or CD-ROM.  
Generic Binary       This option lets you import binary data types from tape, file, or CD-ROM that are not listed here, by defining 

the data format for IMAGINE.  
GeoTIFF       Select this option to import TIFF data (Tagged Image File Format) from file or CD-ROM.  
GIS (ERDAS 7.x)      Select this option to import ERDAS Ver. 7.X GIS data from file or CD-ROM.  
GRASS        Select this option to import GRASS data (raster) from file only.  
GRD        Select this option to import Surfer Grid data.  
GRID       This option available on UNIX and NT platforms only. Select this option to import GRID raster data 

(complement to ARC/INFO - distributed by ESRI) from file or CD-ROM.  
IGDS (Intergraph .dgn File)      Select this option to import an Interactive Graphics Design Software (IGDS) file (also called Intergraph 

Design File, or DGN file) into an Arc/Info coverage.  
IGES     This option applicable to the Vector module only. Select this option to import U.S. Department of Commerce 

Initial Graphics Exchange Standard files (vector) from file or CD-ROM.  
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IRS-1C      Select this option to import an IRS-1C file from file, CD-ROM, or tape into ERDAS IMAGINE format. The 
supported data is distributed by EOSAT or EUROMAP.  

JFIF (JPEG)      Select this option to import a JFIF (JPEG File Interchange Format) file from file, CD-ROM, or tape into 
ERDAS IMAGINE format.  

MIF/MID       Select this option to import MapInfo data to a ARC/INFO coverage.  
MSS Landsat       Select this option to import Landsat MSS data from tape only.  
NLAPS      Select this option to import NLAPS (National Landsat Archive Production System) data or NLAPS Data 

Format (NDF) data from file, tape, or CD-ROM.  
PCX        Select this option to import PCX line art data from file or CD-ROM.  
RADARSAT     Select this option to import CEOS (Committee for Earth Observation Standards) Image Products in the format 

established by RADARSAT, Incorporated (RSI).  
Raster Product Format      Select this option to import RPF frames that are distributed by the Defense Mapping Agency (DMA).  
SDTS Vector      Select this option to import SDTS Topological Vector Profile (TVP) transfer files to vector coverage(s). 
SDTS Raster      Select this option to import SDTS (Spatial Data Transfer Standard) images that conform to the Raster Profile.  
SeaWiFS     Select this option to import SeaWiFS (Sea Wide Field of View Sensor) data in the format produced by Orbital 

Sciences Corporation.  
Shapefile      Select this option to import a Shape file to a coverage.  
SPOT        Select this option to import SPOT satellite data from CD-ROM, tape, or file.  
SPOT (GeoSpot)     Select this option to import Geospot satellite data from CD-ROM, tape, or file.  
Sun Raster        Select this option to import a Sun Raster file from file or CD-ROM.  
TIFF       Select this option to import TIFF data (Tagged Image File Format) from file or CD-ROM.  
TIGER      This option applicable to the Vector module only. Select this option to import U.S. Census Bureau 

Topologically Integrated Geographic Encoding and Referencing System files (vector) from file or CD-ROM. 
The Import TIGER dialog is opened. 

 
The following sections open the Landsat TM dialog: 
TM Landsat ACRES Fast Format 
TM Landsat ACRES Standard Format 
TM Landsat EOSAT Fast Format 
TM Landsat EOSAT Standard Format 
TM Landsat ESA Fast Format 
TM Landsat ESA Standard Format 
TM Landsat IRS Fast Format 
TM Landsat IRS Standard Format 
TM Landsat RADARSAT Fast Format 
TM Landsat RADARSAT Standard Format 

 
The following selections open the Import Landsat-7 Fast L7A dialog: 
Landsat-7 Fast L7A EROS 
Landsat-7 Fast L7A ACRES 
LAN (ERDAS 7.x)    Select this option to import ERDAS Ver. 7.X LAN data from file or CD-ROM. 
 
Export  (If you are exporting an ERDAS IMAGINE file into another format) 
 
ARCGEN       This option applicable to the Vector module only.  
Coverage to Arc_Interchange     This option applicable to the Vector module only.  
Grid to Arc_Interchange     This option applicable to the Vector module only.  
MIF       Select this option to export ARC/INFO coverage to MapInfo data.  
USGS DEM      Select this option to export an .img file into the USGS Digital Elevation Model (DEM) format.  
DFAD      This option applicable to the Vector module only. Click to export ERDAS IMAGINE vector layers to the 

DFAD (file only).  
DGN (Intergraph IGDS)      Select this option to export an Arc/Info coverage to an Interactive Graphics Design Software file (IGDS file, 

also known as Intergraph Design file, or DGN file).  
DLG      This option applicable to the Vector module only. Click to export ERDAS IMAGINE vector files as U.S.G.S 

Digital Line Graphs (file only).  
DOQ        Click to export .img files to Digital Ortho Quads (file only).  
Coverage to DXF      Click to export ERDAS IMAGINE vector coverages, to file only, as AutoCAD Digital Exchange Files 

 (vector).  
GeoTIFF       Click to export .img files as TIFF (Tagged Image File Format) data.  
Generic Binary       This option lets you export binary data types, that are not listed here, to tape or file, by defining the data 

format for IMAGINE.  
GIS (ERDAS 7.x)      Click to export .img files as ERDAS Ver. 7.X GIS files (file only).  
GRASS      Click to export .img files as GRASS data to file only. The Export GRASS Data dialog is opened.  
GRD        Select this option to export  files from IMAGINE  to Surfer Grid files.  
GRID        This option available on UNIX and NT platforms only.  
 
IGDS (Intergraph .dgn File)      Select this option to export an Arc/Info coverage to an Interactive Graphics Design Software file (IGDS file, 

also known as Intergraph Design file, or DGN file).  
IGES        This option applicable to the Vector module only.  
JFIF (JPEG)      Click to export an ERDAS IMAGINE .img file into JFIF (JPEG File Interchange Format) format (file only).  
LAN (ERDAS 7.x)      Click to export .img files as ERDAS Ver. 7.X LAN files (to file only).  
Annotation To DXF      Click to export an IMAGINE annotation file into AutoCAD Digital Exchange Files (vector) format (to file 

only).  
PCX        Click to export .img files as PCX line art files (file only).  
SDTS Vector     Select this option to export vector coverages to SDTS Topological Vector Profile (TVP) transfer files.  
SDTS Raster       Select this option to export an .img file to an SDTS Raster Profile transfer.  
Shapefile       Select this option to export a vector coverage to a shape file.  
TIFF        Click to export .img files as TIFF (Tagged Image File Format) data.  
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TIGER      This option applicable to the Vector module only. Click to export ERDAS IMAGINE vector coverages as 
U.S. Census Bureau Topologically Integrated Geographic Encoding and Referencing System files (vector)(file 
only).  

VPF      This option applicable to the Vector module only. Click to export ERDAS IMAGINE vector layers to ESRI's 
VPF coverages (file only).  

 
 
 

 


